collapse collapse
* User Info
 
 
Welcome, Guest. Please login or register.
* Search

* Board Stats
  • stats Total Members: 987
  • stats Total Posts: 18348
  • stats Total Topics: 2494
  • stats Total Categories: 7
  • stats Total Boards: 33
  • stats Most Online: 500

Recent Posts

Pages: 1 ... 8 9 [10]
91
AoC 0.6 support / Re: Line 99 StartBot.php
« Last post by Kepha on September 24, 2016, 01:46:50 am »
Thank you for the reply Khalem.

Ubuntu Gnone 16.04 LTS.

I just installed XAMPP 5.6 as opposed to LAMP since the latter is optimized for PHP 7.
I am hoping that my problem was passing through the PHP version and the bot code.

- when trying to "php StartBot.php" I get that the program php is currently not installed and suggests me to install php7.0-cli
- when trying "php5 StartBot.php" I get a similar message to also install php7.0-cli

Any suggestions?
92
AoC 0.6 support / Re: Line 99 StartBot.php
« Last post by Khalem on September 22, 2016, 10:01:08 pm »
Which distribution and release are you running?

The bot is failing to load the mysql php module which it needs to operate.
93
AoC 0.6.x Custom/Unofficial modules / Re: New Central itemDB (!item[s|reg])
« Last post by aoc_botter on September 17, 2016, 07:06:44 pm »
Hi,

I have just set up a new bot. I haven't gotten around to installing this module, but wouldn't running this if you still plan on maintaining it.

Server: Crom
Bot: Dancingbot
94
AoC 0.6 support / Re: Unknown dimension error.
« Last post by aoc_botter on September 17, 2016, 06:53:20 pm »
Hey,

Thanks for the help. I did manage to get the bot working, however I had to do a few things. First, the correct config file helped greatly. Much appreciated.

I had to download 6.9 (snapshot) archive...this is the only version that would work. I used MySql 5.0.18 and php5.2.13.

All of these things together got my bot up an running.
95
AoC 0.6.x Custom/Unofficial modules / Re: New Central itemDB (!item[s|reg])
« Last post by Getrix on September 12, 2016, 08:51:06 am »
Yo!

Its been years since i played AoC, but i have stille mantained the itemDB (Not much work, super-uber-stable-host)..
But have come to the day where im doing a server/host cleanup and moving to new hosts..


Is there anyone playing the game and feel this DB is still  must have?


Some DB stats:
500 bots added, from start..

Search queried:
+------+--------+
| year | total  |
+------+--------+
| 2009 | 424226 |
| 2010 | 945343 |
| 2011 | 472590 |
| 2012 | 233203 |
| 2013 | 145303 |
| 2014 |  70917 |
| 2015 |  36604 |
| 2016 |  17572 |
+------+--------+

Items added:
+------+-------+
| year | total |
+------+-------+
| 2009 | 45287 |
| 2010 | 55280 |
| 2011 | 21423 |
| 2012 |  7706 |
| 2013 |  3349 |
| 2014 |  1192 |
| 2015 |   758 |
| 2016 |   358 |
+------+-------+
96
AoC 0.6 support / Line 99 StartBot.php
« Last post by Kepha on September 11, 2016, 02:12:10 pm »
Changing the whole post.

Anyone running the bot on Linux with LAMP installed?

I am encountering the follow error when launching the bot which is related to Line 99 on StartBot.php
Quote
MySQL support required to run this bot

What is happening at this point. Is it related to the *.ini and Main.php files path or the Database?
97
AoC 0.6 support / Re: Unknown dimension error.
« Last post by MuadDib on July 22, 2016, 10:33:46 am »
Hello guys,

Thanks to Bear post, I made some progress.

Trying to get my first bot for Aoc running and so far, it does not seem to like me.

However using same version as bear I went a little further since I actually connect to servers.

Code: [Select]
[LOGIN]  [STATUS]        Authenticating
[Conan Login Server] Connected to aoc-us-um.live.ageofconan.com:7010
[Conan Login Server] Disconnected. [Socket EOF error]
Read error: EOF
Read error: Too many EOF errors, disconnecting.

Linux 3.18.11+
v.0.6.9.(Snapshot) - PHP 5.4.45-0+deb7u4

Code: [Select]
$> php -m
[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dba
dom
ereg
exif
fileinfo
filter
ftp
gettext
hash
iconv
json
libxml
mbstring
mhash
mysql
mysqli
openssl
pcntl
pcre
PDO
pdo_mysql
Phar
posix
Reflection
session
shmop
SimpleXML
soap
sockets
SPL
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
XCache
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]
XCache


What am I missing here?
Any ideas anyone?

I never went this far with the connecting to servers so now I might just need a little push in the right direction.

Thank you in advance.


Edit:
I tested all servers I had in hand
dm09-nj4.ageofconan.com
dm10-nj4.ageofconan.com
on both port 7000 and 7010 without any better results.

--
MD
98
AoC 0.6 support / Re: Unknown dimension error.
« Last post by Bear1968 on July 06, 2016, 05:01:38 am »
Hey aoc_botter!
I just did a fresh install and I am up and running smooth. Here is the ServerList.php I am using. I hope this helps :)
Code: [Select]
<?php
// AO
$server_list['ao']['Testlive'] = array(
    
'server' => 'chat.dt.funcom.com',
    
'port' => 7109,
    
'dim' => 4
);
$server_list['ao']['Rubi-Ka'] = array(
    
'server' => 'chat.d1.funcom.com',
    
'port' => 7105,
    
'dim' => 5

);

// AOC
$server_list['aoc']['EU'] = array(
    
'server' => 'dm10-nj4.ageofconan.com',
    
'port' => 7000
);
$server_list['aoc']['US'] = array(
    
'server' => 'aoc-us-um.live.ageofconan.com',
    
'port' => 7010
);
$server_list['aoc']['Aoctestlive'] = array(
    
'server' => 'testlive.ageofconan.com',
    
'port' => 7010
);


 
// all EU servers use the same login server
 
$server_list['aoc']['Bloodbrand']  = $server_list['aoc']['EU'];
 
$server_list['aoc']['Ahriman']   = $server_list['aoc']['EU'];
 
$server_list['aoc']['Bori']   = $server_list['aoc']['EU'];
 
$server_list['aoc']['Dagon']   = $server_list['aoc']['EU'];
 
$server_list['aoc']['Ymir']   = $server_list['aoc']['EU'];
 
$server_list['aoc']['Hyrkania']  = $server_list['aoc']['EU'];
 
$server_list['aoc']['Aquilonia']  = $server_list['aoc']['EU'];
 
$server_list['aoc']['Twilight']  = $server_list['aoc']['EU'];
 
$server_list['aoc']['Corinthia']  = $server_list['aoc']['EU'];

 
// Merged Servers
 
$server_list['aoc']['Crom']             = $server_list['aoc']['US'];
 
$server_list['aoc']['Fury']             = $server_list['aoc']['US'];


 
// Spanish Servers
 
$server_list['aoc']['Zingara']      = $server_list['aoc']['EU'];
 
$server_list['aoc']['Indomitus']    = $server_list['aoc']['EU'];

 
// French Servers
 
$server_list['aoc']['Ishtar']       = $server_list['aoc']['EU'];
 
$server_list['aoc']['Ferox']        = $server_list['aoc']['EU'];
 
$server_list['aoc']['Stygia']       = $server_list['aoc']['EU'];
 
$server_list['aoc']['Strix']        = $server_list['aoc']['EU'];

 
// German Servers
 
$server_list['aoc']['Asura']        = $server_list['aoc']['EU'];
 
$server_list['aoc']['Ibis']         = $server_list['aoc']['EU'];
 
$server_list['aoc']['Aries']        = $server_list['aoc']['EU'];
 
$server_list['aoc']['Titus']        = $server_list['aoc']['EU'];
 
$server_list['aoc']['Asgard']       = $server_list['aoc']['EU'];

 
// all US servers use the same login server
 
$server_list['aoc']['Gwahlur']      = $server_list['aoc']['US'];
 
$server_list['aoc']['Wiccana']      = $server_list['aoc']['US'];
 
$server_list['aoc']['Bloodspire']   = $server_list['aoc']['US'];
 
$server_list['aoc']['Ironspine']    = $server_list['aoc']['US'];
 
$server_list['aoc']['Tyranny']      = $server_list['aoc']['US'];
 
$server_list['aoc']['Cimmeria']     = $server_list['aoc']['US'];
 
$server_list['aoc']['Agony']        = $server_list['aoc']['US'];

?>


*EDIT
BTW I am using:
Files found https://github.com/J-Soft/BeBot-legacy
php-5.4.8-Win32-VC9-x86
MySQL 5.7.13.0

99
AoC 0.6 support / Re: Unknown dimension error.
« Last post by aoc_botter on July 03, 2016, 04:51:38 am »
So I changed the server address for 'Aoctestlive' to what I think is the correct server, and now I get this error:

Dancingbot [LOGIN]      [STATUS]        Connecting to Aoc server dm09-nj4.ageofconan.com:7010
AOChat: not expecting connect.
100
AoC 0.6 support / Re: Unknown dimension error.
« Last post by aoc_botter on July 01, 2016, 01:44:29 am »
I have 2 php errors right at the beginning if I put "US" in the conf file, then it loads modules, and fails at the end. Still not sure what is going on. I've tried a bunch of versions of php, and I don't know why putting "Crom" in the conf file doesn't work


===================================================

    _/_/_/              _/_/_/                _/

   _/    _/    _/_/    _/    _/    _/_/    _/_/_/_/

  _/_/_/    _/_/_/_/  _/_/_/    _/    _/    _/

 _/    _/  _/        _/    _/  _/    _/    _/

_/_/_/      _/_/_/  _/_/_/      _/_/        _/_/

         An Anarchy Online Chat Automaton

                     And

          An Age of Conan Chat Automaton

          v.0.7.0 - PHP 5.5.37

                  OS: Windows_NT

===================================================

Curl extension loaded
Debug: PHP_INT_SIZE is int(4)

Debug: Precision is 14
Debug: Setting precision to 16...success
Creating main Bot class!
Loaded bot configuration from Conf/Bot.conf

Strict Standards: Non-static method AOChat::get_instance() should not be called
statically in C:\BeBot-master\Sources\Bot.php on line 256
Dancingbot [MAIN]       [START] PHP install detected as being 32 bit

Strict Standards: Non-static method MySQL::get_instance() should not be called s
tatically in C:\BeBot-master\Sources\Bot.php on line 257
Dancingbot [MYSQL]      [START] Loaded MySQL configuration from Conf/Mysql.conf
Dancingbot [MYSQL]      [START] Establishing MySQL database connection....
Dancingbot [MYSQL]      [START] MySQL database connection test successfull.
Dancingbot [COMMODITIES]        [LOAD]  Loading Commodities-modules from 'Commod
ities'
Dancingbot [COMMODITIES]        [LOAD]  00_BasePassiveModule.php
Dancingbot [COMMODITIES]        [LOAD]  01_BaseActiveModule.php
Dancingbot [COMMODITIES]        [LOAD]  BotError.php
Dancingbot [COMMODITIES]        [LOAD]  Message.php

Dancingbot [LOAD]       [ERROR] The specified directory 'Commodities/Aoc' is ina
ccessible!
Dancingbot [MAIN]       [LOAD]  Loading Main-modules from 'Main'
Dancingbot [MAIN]       [LOAD]  03_Security.php
Dancingbot [MAIN]       [LOAD]  05_Maintenance.php
Dancingbot [MAIN]       [LOAD]  06_Preferences.php
Dancingbot [SETTINGS]   [LOAD]  Loaded settings from database.
Dancingbot [MAIN]       [LOAD]  06_Settings.php
Dancingbot [MAIN]       [LOAD]  09_AccessControl.php
Dancingbot [MAIN]       [LOAD]  10_Roster.php
Dancingbot [MAIN]       [LOAD]  11_FlexibleSecurity.php
Dancingbot [MAIN]       [LOAD]  14_Queue.php
Dancingbot [MAIN]       [LOAD]  14_Tools.php
Dancingbot [MAIN]       [LOAD]  15_AoChatWrapper.php
Dancingbot [MAIN]       [LOAD]  15_BotHelp.php
Dancingbot [MAIN]       [LOAD]  15_ChatQueue.php
Dancingbot [MAIN]       [LOAD]  15_Colors.php
Dancingbot [MAIN]       [LOAD]  15_CommandAlias.php
Dancingbot [MAIN]       [LOAD]  15_Log.php
Dancingbot [MAIN]       [LOAD]  15_Notify.php
Dancingbot [MAIN]       [LOAD]  15_OnlineDb.php
Dancingbot [MAIN]       [LOAD]  15_TimerCore.php

Dancingbot [CORE]       [LOAD]  Loading Core-modules from 'Core'
Dancingbot [CORE]       [LOAD]  Alias.php
Dancingbot [CORE]       [LOAD]  Alts.php
Dancingbot [CORE]       [LOAD]  BotStatistics.php
Dancingbot [CORE]       [LOAD]  BuddyList.php
Dancingbot [CORE]       [LOAD]  BuddyQueue.php
Dancingbot [CORE]       [LOAD]  FunFilters.php
Dancingbot [CORE]       [LOAD]  LogonNotifies.php
Dancingbot [CORE]       [LOAD]  ModuleCatcher.php
Dancingbot [CORE]       [LOAD]  PlayerList.php
Dancingbot [CORE]       [LOAD]  PlayerNotes.php
Dancingbot [CORE]       [LOAD]  Professions.php
Dancingbot [CORE]       [LOAD]  Shortcuts.php
Dancingbot [CORE]       [LOAD]  Statistics.php
Dancingbot [CORE]       [LOAD]  StringFilter.php
Dancingbot [CORE]       [LOAD]  Time.php
Dancingbot [CORE]       [LOAD]  User.php

Dancingbot [CORE]       [LOAD]  Loading Core-modules from 'Core/Aoc'
Dancingbot [CORE]       [LOAD]  Items.php
Dancingbot [CORE]       [LOAD]  Whois.php

Dancingbot [LOAD]       [ERROR] The specified directory 'Custom/Core' is inacces
sible!
Dancingbot [MODULES]    [LOAD]  Loading Modules-modules from 'Modules'
Dancingbot [MODULES]    [LOAD]  About.php
Dancingbot [MODULES]    [LOAD]  AccessControlUi.php
Dancingbot [MODULES]    [LOAD]  AdminsUi.php
Dancingbot [MODULES]    [LOAD]  Afk.php
Dancingbot [MODULES]    [LOAD]  AltsUi.php
Dancingbot [MODULES]    [LOAD]  BansManagerUi.php
Dancingbot [MODULES]    [LOAD]  Bid.php
Dancingbot [MODULES]    [LOAD]  BotStatisticsUi.php
Dancingbot [MODULES]    [LOAD]  Calc.php
Dancingbot [MODULES]    [LOAD]  ColorConfigUi.php
Dancingbot [MODULES]    [LOAD]  CommandAliasUi.php
Dancingbot [MODULES]    [LOAD]  Countdown.php
Dancingbot [MODULES]    [LOAD]  FlexibleSecurityUi.php
Dancingbot [SETTINGS]   [SAVED] connected for module irc set to FALSE as datatyp
e bool
Dancingbot [SETTINGS]   [UPDATED]       Updated values for IrcGuestPrefix for mo
dule Irc
Dancingbot [MODULES]    [LOAD]  Irc.php
Dancingbot [MODULES]    [LOAD]  Is.php
Dancingbot [MODULES]    [LOAD]  Logon.php
Dancingbot [MODULES]    [LOAD]  Mail.php
Dancingbot [MODULES]    [LOAD]  MassMsg.php
Dancingbot [MODULES]    [LOAD]  ModulesControlUi.php
Dancingbot [MODULES]    [LOAD]  News.php
Dancingbot [MODULES]    [LOAD]  Notify.php
Dancingbot [MODULES]    [LOAD]  OnlineCount.php
Dancingbot [MODULES]    [LOAD]  OnlineDisplay.php
Dancingbot [MODULES]    [LOAD]  Ping.php
Dancingbot [MODULES]    [LOAD]  PlayerNotesUi.php
Dancingbot [MODULES]    [LOAD]  Points.php
Dancingbot [MODULES]    [LOAD]  PreferencesUi.php
Dancingbot [MODULES]    [LOAD]  Raffle.php
Dancingbot [MODULES]    [LOAD]  Raid.php
Dancingbot [MODULES]    [LOAD]  Rally.php
Dancingbot [MODULES]    [LOAD]  Relay.php
Dancingbot [MODULES]    [LOAD]  Roll.php
Dancingbot [MODULES]    [LOAD]  Roster.php
Dancingbot [MODULES]    [LOAD]  Say.php
Dancingbot [MODULES]    [LOAD]  SetDebug.php
Dancingbot [MODULES]    [LOAD]  SettingsUi.php
Dancingbot [MODULES]    [LOAD]  ShortCutsUi.php
Dancingbot [MODULES]    [LOAD]  Shutdown.php
Dancingbot [MODULES]    [LOAD]  StringFilterUi.php
Dancingbot [MODULES]    [LOAD]  TimerRelay.php
Dancingbot [MODULES]    [LOAD]  TimerUi.php
Dancingbot [MODULES]    [LOAD]  Whois.php
Dancingbot [MODULES]    [LOAD]  nroll.php

Dancingbot [MODULES]    [LOAD]  Loading Modules-modules from 'Modules/Aoc'

Warning: mysqli_fetch_array() expects parameter 2 to be long, string given in C:
\BeBot-master\Sources\Mysql.php on line 205
Dancingbot [MODULES]    [LOAD]  AutoUserAdd.php
Dancingbot [MODULES]    [LOAD]  Blacklist.php
Dancingbot [MODULES]    [LOAD]  Chuck.php
Dancingbot [MODULES]    [LOAD]  City.php
Dancingbot [MODULES]    [LOAD]  CraftClasses.php
Dancingbot [MODULES]    [LOAD]  Gemcutting.php
Dancingbot [MODULES]    [LOAD]  Loot.php
Dancingbot [MODULES]    [LOAD]  Quotes.php

Dancingbot [LOAD]       [ERROR] The specified directory 'Custom/Modules' is inac
cessible!
Unknown dimension Us
C:\BeBot-master>pause
Press any key to continue . . .
Pages: 1 ... 8 9 [10]
* Recent Posts
Linked objects in chat by bitnykk
[November 02, 2022, 10:56:58 am]


0.7.x updates for AO by bitnykk
[September 01, 2022, 03:25:38 pm]


0.7.x updates for AoC by bitnykk
[September 01, 2022, 03:25:22 pm]


Website back up and quick status update by bitnykk
[July 30, 2021, 04:56:19 pm]


AO Bots - discord server by bitnykk
[January 31, 2021, 03:50:48 am]

* Who's Online
  • Dot Guests: 197
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.
* Forum Staff
bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2022, SimplePortal