collapse collapse
* User Info
 
 
Welcome, Guest. Please login or register.
* Search

* Board Stats
  • stats Total Members: 987
  • stats Total Posts: 18348
  • stats Total Topics: 2494
  • stats Total Categories: 7
  • stats Total Boards: 33
  • stats Most Online: 500

Author Topic: Guildbot too noisy.  (Read 4159 times)

0 Members and 1 Guest are viewing this topic.

Offline 711

  • BeBot Rookie
  • *
  • Posts: 3
  • Karma: +0/-0
Guildbot too noisy.
« on: November 12, 2008, 06:46:26 pm »
My guildbot seems to love announcing things nobody wants to hear and saying things like "Bot is online ::: Roster update starting ::: System busy" or "Roster update failed! Funcom XML returned 0 members ::: System ready".

Now, I'm not concerned that it's not finding the roster, because I didn't configure the guild id.  In fact, I don't want it to do that.  I just want it to link the guestchannel and guildchannel and not say anything, ever.

How can I make the bot quieter?

Thanks in advance.

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: Guildbot too noisy.
« Reply #1 on: November 12, 2008, 10:29:11 pm »
well roster can be turned off useing !set member (i think)

Offline 711

  • BeBot Rookie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Guildbot too noisy.
« Reply #2 on: November 13, 2008, 04:55:54 am »
Well I reviewed every setting again, both ingame, and directly on the mysql table, and found nothing about turning off roster updating, so I tried enabling or disabling modules to no luck, so I just opened up bebot/core/Roster.php and removed the bits that tell it what to do in the event that it THINKS there should be a roster update.

Code: [Select]
function update_guild()
{

}

No more unsightly spam.  :)

However, I guess someone should think about implementing a setting to turn this off without having to edit .php files?

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: Guildbot too noisy.
« Reply #3 on: November 13, 2008, 06:30:11 am »
the exact command was
!set members Update Off

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: Guildbot too noisy.
« Reply #4 on: November 13, 2008, 06:31:39 am »
but looking at the location of the file you edited it apears you are NOT running 0.5

Offline 711

  • BeBot Rookie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Guildbot too noisy.
« Reply #5 on: November 13, 2008, 06:42:09 am »
Just about to say... command not recognized... I think I'm on a an older version.  I guess I must have had some problems with the latest version and forgotten about it.  =P  Sorry about that.

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: Guildbot too noisy.
« Reply #6 on: November 13, 2008, 07:11:58 am »
well if you decided to upgrade again and still have an Issue Post it and we can Probably help you

 

* Recent Posts
Linked objects in chat by bitnykk
[November 02, 2022, 10:56:58 am]


0.7.x updates for AO by bitnykk
[September 01, 2022, 03:25:38 pm]


0.7.x updates for AoC by bitnykk
[September 01, 2022, 03:25:22 pm]


Website back up and quick status update by bitnykk
[July 30, 2021, 04:56:19 pm]


AO Bots - discord server by bitnykk
[January 31, 2021, 03:50:48 am]

* Who's Online
  • Dot Guests: 90
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.
* Forum Staff
bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2022, SimplePortal