collapse collapse
* User Info
 
 
Welcome, Guest. Please login or register.
* Search

* Board Stats
  • stats Total Members: 987
  • stats Total Posts: 18348
  • stats Total Topics: 2494
  • stats Total Categories: 7
  • stats Total Boards: 33
  • stats Most Online: 500

Author Topic: Error: BeBot requires PHP version 5.2.0 or later to work  (Read 4159 times)

0 Members and 1 Guest are viewing this topic.

Offline trousers

  • BeBot User
  • **
  • Posts: 22
  • Karma: +0/-0
Error: BeBot requires PHP version 5.2.0 or later to work
« on: October 21, 2008, 06:15:13 pm »
Hey Guys, I just grabbed 0.5.4 off the home page and tried to throw it up but I am hitting a Snag...

# php StartBot.php

[Splash Screen]

# BeBot requires PHP version 5.2.0 or later to work.

# php -version
PHP 5.2.6 (cli) (built: May  7 2008 10:17:07)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies

I'm not super good at unix, so Can someone point me in the right direction please?

Thanks!


Offline trousers

  • BeBot User
  • **
  • Posts: 22
  • Karma: +0/-0
Re: Error: BeBot requires PHP version 5.2.0 or later to work
« Reply #1 on: October 21, 2008, 06:23:35 pm »
I just noticed this:

When i start both the 5.4 Version of my Bots, and the old 4.2 Versions, they both display this on the Splash Screen:

            v.0.4.2 - PHP 5.1.4


             v.0.5.4.svn(snapshot) - PHP 5.1.4

Could it be a variable I do not have set right somewhere?

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: Error: BeBot requires PHP version 5.2.0 or later to work
« Reply #2 on: October 21, 2008, 06:26:54 pm »
you might have more than 1 install and its useing the wrong 1

Offline trousers

  • BeBot User
  • **
  • Posts: 22
  • Karma: +0/-0
Re: Error: BeBot requires PHP version 5.2.0 or later to work
« Reply #3 on: October 21, 2008, 06:29:13 pm »
I think that is the case ...

I just went to /usr/local/php5/bin and did a ./php -version and it kicked out 5.1.

Any idea where PHP would install if I did a YUM Update on a Fedora 5 system?

Offline Alreadythere

  • BeBot Maintainer
  • BeBot Hero
  • ******
  • Posts: 1288
  • Karma: +0/-0
Re: Error: BeBot requires PHP version 5.2.0 or later to work
« Reply #4 on: October 21, 2008, 06:42:32 pm »
In your first post you show a php 5.2 version output without any path.

Simply try which php to get the path to that php.

Offline trousers

  • BeBot User
  • **
  • Posts: 22
  • Karma: +0/-0
Re: Error: BeBot requires PHP version 5.2.0 or later to work
« Reply #5 on: October 21, 2008, 07:19:27 pm »
That worked!

Seems it installed to /usr/bin/php.  This is a very nifty command, thanks for showing it to me!

Now it's saying "MySQL support required to run this bot"

I'm trying to use the same Database as the original 4.2 Bot - Do I also need a new version of MySQL?

P.s. I thought this would be helpful to show:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 3 to server version: 5.0.22

Offline Alreadythere

  • BeBot Maintainer
  • BeBot Hero
  • ******
  • Posts: 1288
  • Karma: +0/-0
Re: Error: BeBot requires PHP version 5.2.0 or later to work
« Reply #6 on: October 21, 2008, 07:35:56 pm »
Server should work. You need to make sure that php got either compiled with mysql enabled or you include the mysql library in your php.ini.

Should be something like mysql.so, but no clue about the path.

Or maybe you haven't installed it, not sure what the packages for fedora contain.

Offline trousers

  • BeBot User
  • **
  • Posts: 22
  • Karma: +0/-0
Re: Error: BeBot requires PHP version 5.2.0 or later to work
« Reply #7 on: October 22, 2008, 04:22:54 pm »
I'm so Confused :(

I Uninstalled the PHP 5.2 that got Installed with YUM since I didn't know how to install it with options and downloaded PHP 5.2.6 and decided to deploy it by hand...

I did this all before when I setup 4.x but now it's killing me.

When I launch Bebot I get:
Sockets extention required to run this bot

When I configured PHP I used the following script:

cd /usr/local/src/php-5.2.6
make distclean
./configure \
        --prefix=/usr/local/php52/ \
        --with-mysql=/usr/local/mysql \
        --with-apxs2=/usr/local/apache2/bin/apxs \
        --with-xsl \
        --with-gdbm \
        --with-gd \
        --with-aokex
        --with-gmp=/usr/local/lib \
        --with-freetype=/usr/include/freetype/ \
        --with-zlib-dir=/usr/include \
        --with-ttf \
        --with-jpeg-dir=/usr/lib \
        --enable-sockets \
        --enable-bcmath

Then did a MAKE then MAKE INSTALL

And Now I'm like dead in the water and sad :(
« Last Edit: October 22, 2008, 04:25:53 pm by trousers »

Offline Glarawyn

  • BeBot Hero
  • ******
  • Posts: 521
  • Karma: +0/-0
Re: Error: BeBot requires PHP version 5.2.0 or later to work
« Reply #8 on: October 23, 2008, 07:22:21 pm »
I'd recommend going back to the yum packaged version, but that's me. :)

Personally, I use Ubuntu so I'm not sure on what you need to do to get things working on Fedora. I looked a bit, and it seems you may need to do something like:

yum install php php-extras


If you switch to Ubuntu I can tell you exactly what packages you need to install to make BeBot work.  :P


 

* Recent Posts
Linked objects in chat by bitnykk
[November 02, 2022, 10:56:58 am]


0.7.x updates for AO by bitnykk
[September 01, 2022, 03:25:38 pm]


0.7.x updates for AoC by bitnykk
[September 01, 2022, 03:25:22 pm]


Website back up and quick status update by bitnykk
[July 30, 2021, 04:56:19 pm]


AO Bots - discord server by bitnykk
[January 31, 2021, 03:50:48 am]

* Who's Online
  • Dot Guests: 48
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.
* Forum Staff
bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2022, SimplePortal