collapse collapse
* User Info
 
 
Welcome, Guest. Please login or register.
* Search

* Board Stats
  • stats Total Members: 987
  • stats Total Posts: 18348
  • stats Total Topics: 2494
  • stats Total Categories: 7
  • stats Total Boards: 33
  • stats Most Online: 500

Author Topic: !itemreg broken?  (Read 3387 times)

0 Members and 1 Guest are viewing this topic.

Offline Getrix

  • Contributor
  • *******
  • Posts: 509
  • Karma: +0/-0
!itemreg broken?
« on: November 13, 2008, 02:21:27 pm »
After the last dev(svn) updates my bot has not submitted any new items found.
Was running a short debug yesterday and here is some notes:

"!itemreg blabla" "!itemreg KNOWN-ITEM" "!itemreg UKNOWN-ITEM"
* Does not relay to IRC, the bot is then taking it as a command.
* It does not take any action, as i dont get back "Its not a item ...." in tells or gc


Not sure how the submit is accepted, but i tried to use the link right in web browser and only get "3" as a feedback

But it seems to me that the bot doesn send anything at all..

So before more debugging, i just wonder if its only me that have this problem.

http://aocdb.lunevo.net/botsubmit/v3/?lowid=3905810&highid=3905810&ql=60&lowcrc=6088425b%3A911b41f%3Abeca01b3%3Aac1ed08b&highcrc=6088425b%3A911b41f%3Abeca01b3%3Aac1ed08b&color=6d8dff&name=Guthorm%5C%27s+Bracers&server=SERVER&guildname=GUILDNAME&username=NICK&checksum=cfcd208495d565ef66e7dff9f98764da
Success is not final, failure is not fatal: it is the courage to continue that counts.
- Sorry, i dont have time to reply question on PM. Make a topic.

Offline OTGBot

  • BeBot User
  • **
  • Posts: 29
  • Karma: +0/-0
Re: !itemreg broken?
« Reply #1 on: January 11, 2009, 02:12:13 pm »
I have not tried that, but I'm assuming I get the same results.

OTGBot

Offline OTGBot

  • BeBot User
  • **
  • Posts: 29
  • Karma: +0/-0
Re: !itemreg broken?
« Reply #2 on: January 13, 2009, 04:40:14 pm »
Ok..so I tried doing a manual entry and I got back '3'.  Which I assume is an error condition.  At least the Items.php core module looks for a 1 or 2.  else return error. 


 

* Recent Posts
Linked objects in chat by bitnykk
[November 02, 2022, 10:56:58 am]


0.7.x updates for AO by bitnykk
[September 01, 2022, 03:25:38 pm]


0.7.x updates for AoC by bitnykk
[September 01, 2022, 03:25:22 pm]


Website back up and quick status update by bitnykk
[July 30, 2021, 04:56:19 pm]


AO Bots - discord server by bitnykk
[January 31, 2021, 03:50:48 am]

* Who's Online
  • Dot Guests: 43
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.
* Forum Staff
bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2022, SimplePortal