collapse collapse
* User Info
 
 
Welcome, Guest. Please login or register.
* Search

* Board Stats
  • stats Total Members: 987
  • stats Total Posts: 18350
  • stats Total Topics: 2494
  • stats Total Categories: 7
  • stats Total Boards: 33
  • stats Most Online: 1144

Author Topic: Script module  (Read 21656 times)

0 Members and 1 Guest are viewing this topic.

Offline Poonjab

  • BeBot User
  • **
  • Posts: 59
  • Karma: +0/-0
Re: Script module
« Reply #15 on: November 20, 2009, 03:02:47 am »
I can't get this module to work right...  It finds the script.lst file and reflects changes I make to the file, but it can't seem to find any actual txt files I put in the folder.

Any ideas?

Edit: OK, I got it working now, but it's not quite what I'm looking for, but a start.  I'll see what I can do with it.
« Last Edit: November 20, 2009, 07:39:31 am by Poonjab »

Offline Isime

  • BeBot Rookie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Script module
« Reply #16 on: March 26, 2010, 04:43:21 pm »
I am also having trouble with this.

In game I use the /tell botname !scripts kos.txt
and the response i get is /tell botname !help

I changed the script folder from capital S to lower case s and that didn't work.
I did however notice when I start the bot and when the modules load up I see the programming of the script file show up.  Is that normal?

Here is where i put the files.

C:\php5\custom\modules\scripts.php

c:\php5\scripts\crafters.txt
                         kos.txt
                         script.1st
are all in the same directory

Do I need to modify anything in the script.1st file?


« Last Edit: March 26, 2010, 04:47:27 pm by Isime »

Offline Drizzurdeen

  • BeBot Apprentice
  • ***
  • Posts: 193
  • Karma: +0/-0
    • Obsidian-Cult
Re: Script module
« Reply #17 on: March 26, 2010, 05:16:10 pm »
hmmm just try .... !scripts kos

u should use the name of the scripts without .txt only use the name

hope this helps

Offline Kyr

  • BeBot Apprentice
  • ***
  • Posts: 177
  • Karma: +0/-0
Re: Script module
« Reply #18 on: March 26, 2010, 07:00:08 pm »
Quote
I did however notice when I start the bot and when the modules load up I see the programming of the script file show up.  Is that normal?

No this is not normal.  Might be a misplaced character at the start of the script.php file.  Try DL it again.  If that doesn't help.   Attach the file here and/or paste some of what is shown on start up.  It may be recorded in a log file.

Offline Isime

  • BeBot Rookie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Script module
« Reply #19 on: March 26, 2010, 09:38:43 pm »
Ok,

I was able to get the module to work.  the Script.php file has a typo on the 1st line.

it reads <?
and I made is <?PHP

and the module loaded and worked.. now when I use the script in AOC game people click the script but I am seeing the BOT show "I only listed to members of this bot" or something of that sort..

Being I am a member it works for me just fine, but it doesn't for anyone else outside of guild.


Offline Kyr

  • BeBot Apprentice
  • ***
  • Posts: 177
  • Karma: +0/-0
Re: Script module
« Reply #20 on: March 27, 2010, 06:49:13 pm »
Interesting, works fine for me with <?.

Thanks for posting the solution.

~Kyr

Offline Nysom

  • BeBot Rookie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: Script module
« Reply #21 on: May 23, 2010, 12:56:24 am »
Where / how do I add in what scripts are listed? When I type !scripts there are none listed.

Offline Khalem

  • BeBot Founder
  • Administrator
  • ********
  • Posts: 1169
  • Karma: +0/-0
    • http://www.ancarim.com
Re: Script module
« Reply #22 on: May 23, 2010, 01:12:32 pm »
Interesting, works fine for me with <?.

Thanks for posting the solution.

~Kyr

As a general rule, always use <?php  as allowing <? only is not ensured to be enabled on the system.
This is controlled by the short_open_tag php config directive.
BeBot Founder and Fixer Kingpin

Offline Kyr

  • BeBot Apprentice
  • ***
  • Posts: 177
  • Karma: +0/-0
Re: Script module
« Reply #23 on: May 27, 2010, 05:28:04 am »
ahh, good to know, thanks.
~Kyr

Offline dragonjr

  • BeBot Apprentice
  • ***
  • Posts: 131
  • Karma: +0/-0
Re: Script module
« Reply #24 on: September 04, 2010, 10:30:38 pm »
i cant seem to get the mod for the scripts ive tried opening it with notepad++ and it came up with some jiberish that i couldnt understand bow do i open it and down load it to get it to get it to work. any help would be great
thanks

Offline dragonjr

  • BeBot Apprentice
  • ***
  • Posts: 131
  • Karma: +0/-0
Re: Script module
« Reply #25 on: November 08, 2010, 01:49:06 pm »
nvm i i got the mod to work but now when i add things to the list i run into a issue that when i get to a certin point in adding to the list i save and then i do !scripts i dont see the one i just put in there or it will say 10.<a
So how do i fix this ?
the other issue is when i can get the link to work the script is showing the some of the coding but if i just type in the script normal the coding is fine how do i fix this as well.
thanks for all the help
« Last Edit: November 08, 2010, 02:08:12 pm by dragonjr »

 

* Recent Posts
0.7.x updates for AO by bitnykk
[January 26, 2023, 03:00:58 pm]


0.7.x updates for AoC by bitnykk
[January 26, 2023, 03:00:39 pm]


Linked objects in chat by bitnykk
[November 02, 2022, 10:56:58 am]


Website back up and quick status update by bitnykk
[July 30, 2021, 04:56:19 pm]


AO Bots - discord server by bitnykk
[January 31, 2021, 03:50:48 am]

* Who's Online
  • Dot Guests: 127
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.
* Forum Staff
bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2023, SimplePortal