collapse collapse
* User Info
 
 
Welcome, Guest. Please login or register.
* Search

* Board Stats
  • stats Total Members: 989
  • stats Total Posts: 18365
  • stats Total Topics: 2500
  • stats Total Categories: 7
  • stats Total Boards: 35
  • stats Most Online: 1144

Author Topic: City Alien attack Wave mod  (Read 48777 times)

0 Members and 1 Guest are viewing this topic.

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #15 on: February 07, 2011, 03:53:01 am »
hmm i got Spam and Channel on both, but it isnt working :/
Download the latest version from the begining of this thread. :)

Offline Zweiblum

  • BeBot Apprentice
  • ***
  • Posts: 135
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #16 on: February 07, 2011, 02:24:51 pm »
thx for it, much less spam :D

One thing i even cant find in the code i get a empty Warning after the Gen warning
Code: [Select]
[org] bot: Warning Alien General INCOMING!!
[org] bot: Warning

The relay into the PG still isnt working :/

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #17 on: February 08, 2011, 02:50:40 am »
One thing i even cant find in the code i get a empty Warning after the Gen warning
Code: [Select]
[org] bot: Warning Alien General INCOMING!!
[org] bot: Warning

The last Warning is from the way the timers get set up when the timerclass is created. I have not figured a way around that yet.
This line specifically:
Code: [Select]
$nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, -2, 0, "", "");

The relay into the PG still isn't working :/

The chat relay is really dependent on how you have your relays working. For this to work I think you need to have the wave spam go to both channels and you may need the public timer enabled so the wave announcements show in guest chat (private group). Your relay would need to be setup to use the PG channel for relays also.

--OR-- if they all share a database you can use the DB method for relays. This really depends on how your relay is configured.

You may want to try this and make sure the "Channel" announcements go to "both" channels:
Code: [Select]
/tell bot !settings AlienAttack
And look at the channel settings (set it to Both).

I have 2 bots using the DB method and this works fine there. :)

Shelly

Offline Zweiblum

  • BeBot Apprentice
  • ***
  • Posts: 135
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #18 on: February 08, 2011, 12:01:39 pm »
Hey shelly,
thx for looking into this :)

Wave_spam does only have the option gc or tells or both, but not pg.
Channel is set to both, but i can see in the commandline of the relaybot (yes im using a 3th bot as relay) that no output of orgbot1 is relayed into the pg.

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #19 on: February 09, 2011, 01:42:14 am »
Hey shelly,
thx for looking into this :)

Wave_spam does only have the option gc or tells or both, but not pg.
Channel is set to both, but i can see in the commandline of the relaybot (yes im using a 3th bot as relay) that no output of orgbot1 is relayed into the pg.

Yeah... looked into it further... the setting you want is in the timers not in this module. :)

Try /tell bot !settings timers and look for:
Quote
Global:  On
  Description: Are all timers global? Notices for global timers are sent both to guild chat and private group. Global timers are listed in every timer listing too.
  Change to: [ On | Off ]

GuestChannel:  both
  Description: Should an timer started in guestchannel or org-chat show up in both those channels or just in the channel of origin?
  Change to: [ both | origin ]
.
.
.

Relay:  On
  Description: Should new timer be relayed to all relay bots using the established relay network (See module/Relay.php for more informations about relaying)?
  Change to: [ On | Off ]

That is probably where you want to look. I think the last setting it the one you really want. :)

Shelly
« Last Edit: February 09, 2011, 02:02:06 am by Shelly »

Offline Zweiblum

  • BeBot Apprentice
  • ***
  • Posts: 135
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #20 on: February 09, 2011, 10:42:24 am »
Hey Shelly,

if set everything u said, a PublicTimer about the cloak is enabled or disabled is relayed to each bot.
But that doesnt do anything with the wave_spam :/

I tried the 1st time to look trough the code.
Maybe the $channel setting isnt for extprivgroup?
Because in the doc, it is mentioned that there is a privgroup (i think of the bot itsself) and a extprivgroup (i think of the realybot).
So maybe "both" or "pgroup" isnt for a realyvbot or extpgroup ?

I noticed at the preg_match() functioned that there is a $msg at the end of the command, and does commands relay trough each other, maybe thats a problem?

With ur DB methode, does the wave_spam even be relayed or only the Public_cloakreminder_Timer ?

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #21 on: February 13, 2011, 04:35:45 am »
I tried to re-verify and found the timers were not relayed to the Private Group. Only the announcements.So... I am at a loss as to how to get this to relay between bots. Even the DB method is not working as I thought it was.

Sorry,
Shelly

Offline Zweiblum

  • BeBot Apprentice
  • ***
  • Posts: 135
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #22 on: February 14, 2011, 09:39:06 pm »
hmm i see in the doc that for $channel there is a parameter called extpgroup, maybe if u set $channel to set it should relay?

Offline Bramdo

  • BeBot Rookie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #23 on: February 15, 2011, 07:05:29 pm »
Heya,

I recently downloaded this Module, i unpacked it, renamed it and put into to C:\...\Bebot\Custom\modules.

When i try to start the bot now it says:

Fatal error: Cannot redeclare class AlienAttack in C:\..\Bebot\custom\modules\AlienAttack.php on line 421

And the only thing i can find on line 421 is "}"

Since I'm some kind of php gimp I hope you guys could help

Thanks ahead,
Bramdo

Offline Zweiblum

  • BeBot Apprentice
  • ***
  • Posts: 135
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #24 on: February 15, 2011, 08:34:00 pm »
u have to put in into ../modules/ao because its not a custom module, its a core module and so the bot now tries to start both scripts.

u should rename the original AlienAttack.php (e.q. _AlienAttack.php) if u want to "go back"

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #25 on: February 21, 2011, 03:26:30 pm »
Hey Shelly,

if set everything u said, a PublicTimer about the cloak is enabled or disabled is relayed to each bot.
But that doesnt do anything with the wave_spam :/

I tried the 1st time to look trough the code.
Maybe the $channel setting isnt for extprivgroup?
Because in the doc, it is mentioned that there is a privgroup (i think of the bot itsself) and a extprivgroup (i think of the realybot).
So maybe "both" or "pgroup" isnt for a realyvbot or extpgroup ?

I noticed at the preg_match() functioned that there is a $msg at the end of the command, and does commands relay trough each other, maybe thats a problem?

With ur DB methode, does the wave_spam even be relayed or only the Public_cloakreminder_Timer ?

The AlienAttack module uses the timers module, so I believe the problem exists there. This module just sets up specialized timers. The timers module is what sends out the actual wave spam.

I am still looking into seeing if I can get it to tell the timers module to globally export the outputs for this set of timers so they come out properly and thus can be relayed.

Offline Zweiblum

  • BeBot Apprentice
  • ***
  • Posts: 135
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #26 on: February 22, 2011, 10:40:22 am »
thank you very much for looking into this! :)

Offline mcgunman

  • BeBot Rookie
  • *
  • Posts: 17
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #27 on: March 20, 2011, 10:14:09 pm »
btw timer doesn't fit for my city.. i got the following

Code: [Select]
$nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, -2, 0, "", "Alien General Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 120, "", "8th Alien Wave Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 240, "", "7th Alien Wave Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 360, "", "6th Alien Wave Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 480, "", "5th Alien Wave Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 600, "", "4th Alien Wave Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 720, "", "3rd Alien Wave Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 840, "", "2nd Alien Wave Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 990, "", "1st Alien Wave Incoming");
                $nextid = $this -> bot -> core("timer") -> create_timer_class_entry($classid, $nextid, 1290, "", "The City Cloak has been Dropped!!");

Code: [Select]
$this -> bot -> core("timer") -> add_timer(false, "city", 1290, $player." wave", "internal", 0, "AlienWave");
every wave takes 120 sec but 2nd takes 150 and till 1st wave 5min

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #28 on: April 18, 2011, 03:51:07 am »
Thanks,

I modified the distributed code in the beginning of this thread.

Shelly

Offline Tussa

  • BeBot Rookie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: City Alien attack Wave mod
« Reply #29 on: July 23, 2014, 06:43:36 pm »
Hi guys,

My Bebot orgbot doesn't give me a wave counter, so I figured I would use this module. But which of the two files should I get? Shelly posted both  AlienAttack.php and AlienAttack_mod4.php. Do I need both? One in core and one in custom? Or only one of them? If so, what is the actual difference between these two files? "Less spam" it says, but what does that entail?

 

* Recent Posts
0.8.x updates for AO by bitnykk
[June 23, 2024, 03:19:47 pm]


0.8.x updates for AoC by bitnykk
[June 23, 2024, 03:19:44 pm]


[AoC] special char for items module by bitnykk
[February 09, 2024, 09:41:18 pm]


BeBot still alive & kicking ! by bitnykk
[December 17, 2023, 12:58:44 am]


Bebot and Rasberry by bitnykk
[November 29, 2023, 11:04:14 pm]

* Who's Online
  • Dot Guests: 299
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.
* Forum Staff
bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2024, SimplePortal