collapse collapse
* User Info
 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?
* Search

* Board Stats
  • stats Total Members: 987
  • stats Total Posts: 18327
  • stats Total Topics: 2493
  • stats Total Categories: 7
  • stats Total Boards: 33
  • stats Most Online: 500

Author Topic: Roster update failed  (Read 6246 times)

0 Members and 1 Guest are viewing this topic.

Offline Foodor

  • BeBot Rookie
  • *
  • Posts: 6
  • Karma: +0/-0
Roster update failed
« on: May 30, 2013, 09:14:28 pm »
Hey fellas,

I'm sure this has been discussed million times but didn't find any direct correction for this while searching. So I still have this old problem:

Buchio [CORE]   [INC_GANNOUNCE] Detected org name as: OnTT
Buchio [SETTINGS]       [LOAD]  Loaded settings from database.
Buchio [ROSTER] [UPDATE]        Starting roster update for guild id: 9605 on RK1
Buchio [ROSTER] [UPDATE]        XML for the  guild  obtained
Buchio [ROSTER] [UPDATE]        Roster update failed. Funcom XML returned 0 members.
Buchio [ROSTER] [UPDATE]        Starting roster update for guild id: 9605 on RK1
Buchio [ROSTER] [UPDATE]        XML for the  guild  obtained
Buchio [ROSTER] [UPDATE]        Roster update failed. Funcom XML returned 0 members.


I did fix file 10_Roster.php like this as guided in one other thread:

#->get_site("http://people.anarchy-online.com/org/stats/d/$dim/name/$id/basicstats.xml");
                ->get_site("http://people.anarchy-online.com/org/stats/d/1/name/$id/basicstats.xml");

But still it keeps saying roster update failed 0 members

Foo

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
  • Karma: +0/-0
Re: Roster update failed
« Reply #1 on: June 01, 2013, 04:21:37 am »
Try promoting your bot character in the org to officer level.

Offline Foodor

  • BeBot Rookie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Roster update failed
« Reply #2 on: June 10, 2013, 10:14:12 pm »
Now I get this kind of error

Buchio [LOGIN]  [STATUS]        Connecting to ao server chat.d1.funcom.com:7105
Buchio [LOGIN]  [STATUS]        Authenticating xxxxx
Buchio [LOGIN]  [STATUS]        Logging in Buchio
Buchio [LOGIN]  [RESULT]        OK
Buchio [SETTINGS]       [LOAD]  Loaded settings from database.
Buchio [CORE]   [INC_GANNOUNCE] Detected org name as: OnTT
Read error: EOF
Buchio [CONN]   [ERROR] Bot has disconnected. Reconnecting in 60 seconds.

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
  • Karma: +0/-0
Re: Roster update failed
« Reply #3 on: June 10, 2013, 11:08:59 pm »
What version of the bot are you running?

You may want to look at this thread and see if it helps you --> http://bebot.link/ao-0-6-support/server-merge!/msg18432/#msg18432

I would also make sure that account is good by logging in via a client to make sure the bot character is activated.

Just my thoughts...

Shelly
« Last Edit: June 10, 2013, 11:11:54 pm by Shelly »

Offline Khalem

  • BeBot Founder
  • Administrator
  • ********
  • Posts: 1169
  • Karma: +0/-0
    • http://www.ancarim.com
Re: Roster update failed
« Reply #4 on: August 06, 2013, 07:57:34 pm »
Apologies for late reply.

Please try the latest snapshot:
https://github.com/J-Soft/BeBot-legacy/archive/master.zip
BeBot Founder and Fixer Kingpin

 

* Recent Posts
0.7.x updates for AO by bitnykk
[February 16, 2021, 05:39:03 pm]


0.7.x updates for AoC by bitnykk
[February 16, 2021, 05:38:51 pm]


AO Bots - discord server by bitnykk
[January 31, 2021, 03:50:48 am]


AO public Raidforall by bitnykk
[January 18, 2021, 05:02:22 pm]


Assistance with AAmon by bitnykk
[January 03, 2021, 06:21:18 am]

* Who's Online
  • Dot Guests: 26
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.
* Forum Staff
bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2021, SimplePortal